電訊茶室's Archiver

tommy0204 發表於 2019-1-23 18:44

多wan分流問題

請問各位ROS有沒有進行下例分流:
如要去 youtube.com 使用ISP A 線路
如要去 yahoo.com 使用ISP B 線路
即指定網站使用指定出口

角色 發表於 2019-1-23 18:56

Based on the following thread and my past experience, you may put marks for gateway WAN2, others will go for the default gateway WAN1.

[url]https://forum.mikrotik.com/viewtopic.php?t=128524[/url]

tommy0204 發表於 2019-1-23 19:42

[i=s] 本帖最後由 tommy0204 於 2019-1-23 19:44 編輯 [/i]

唔該角色!:D
不過睇完都唔明....:funk:
我忘了說我不是用FIX IP的

角色 發表於 2019-1-23 20:01

我记得你可以用hostname!我看看是否可以找到别的link:

[url]https://forum.mikrotik.com/viewtopic.php?t=129171[/url]

[url]https://wiki.mikrotik.com/wiki/Policy_Base_Routing[/url]

gfx86674 發表於 2019-1-25 01:21

[b]回復 [url=http://www.telecom-cafe.com/forum/redirect.php?goto=findpost&pid=45922&ptid=7298]1#[/url] [i]tommy0204[/i] [/b][code]/ip firewall address-list
add list=youtube address="youtube.com"
add list=yahoo address="yahoo.com"

/ip firewall mangle
add action=mark-routing chain=prerouting dst-address-list=youtube new-routing-mark=ispA
add action=mark-routing chain=prerouting dst-address-list=yahoo new-routing-mark=ispB

/ip route
add distance=1 gateway=10.0.1.254 routing-mark=ispA
add distance=1 gateway=10.0.2.254 routing-mark=ispB[/code]

tommy0204 發表於 2019-1-25 19:04

謝謝兩位!用gfx86674方法已成功進行分流

Lobo826 發表於 2019-4-1 14:11

[quote]回復  tommy0204
[size=2][color=#999999]gfx86674 發表於 2019-1-25 01:21[/color] [url=http://www.telecom-cafe.com/forum/redirect.php?goto=findpost&pid=45936&ptid=7298][img]http://www.telecom-cafe.com/forum/images/common/back.gif[/img][/url][/size][/quote]


請問這個方法是否也適用於以下?
ISP A = HKBN dynamic IP
ISP B = PCCW dynamic IP

Default route 使用ISP A 線路
指定VPN 連去另一端VPN server 使用ISP B 線路

已經跟了以下網址設定了DUAL Wan Dynamic Dhcp-Client Load Balance, 但一直找不到怎把VPN設置指定WAN出口:dizzy:
[url]https://virtualitsupport.wordpress.com/2016/03/20/2-wan-dynamic-dhcp-client-load-balance/[/url]

Thank you!!

gfx86674 發表於 2019-4-2 00:33

[i=s] 本帖最後由 gfx86674 於 2019-4-2 00:35 編輯 [/i]

[quote]請問這個方法是否也適用於以下?
ISP A = HKBN dynamic IP
ISP B = PCCW dynamic IP

Default route 使 ...
[size=2][color=#999999]Lobo826 發表於 2019-4-1 14:11[/color] [url=http://www.telecom-cafe.com/forum/redirect.php?goto=findpost&pid=46633&ptid=7298][img]http://www.telecom-cafe.com/forum/images/common/back.gif[/img][/url][/size][/quote]
policy route設置:
chain選擇output,src-address省缺,dst-address設置vpn地址即可。

假設對端地址是ddns,將ddsn地址輸入到address-list list=xxx,
系統會將ddns轉譯成address。
在設置policy route時,將上述dst-address置換為dst-address-list=xxx即可。

kingwilliam 發表於 2019-4-2 07:46

[i=s] 本帖最後由 kingwilliam 於 2019-4-2 08:27 編輯 [/i]

multi wan outgoing load balancing 個人都有少少經驗可以分享。

通常設定都是round robin型式,如果是2條BB, 即是輪流分配1 2 1 2。。。

這個好處當然是即時較能提升。

但同時出現好多問題,通常 或 絕大部份都係security 。 這個security 不是你會給入侵或個資外漏。而係server side 發現同1個request有多過1個ip同時request, server side就安全問題即時logout 或 terminate 你當時個request.

例如:支付寶,mytvsuper Set top box,internet banking

這時可能會在routing做設定,戊一個domain, host或subnet 指定走戊一條BB。但這時又跌落另一個深淵 ,你不知網頁或apps內走去那,你會不停睇log(dns, firewall) ,做online monitor 。跟住就惡性循環 不知何時 又出現一些問題 又做fault isolation ,同時又發現個routing table 跟著時日和上網種類不斷成長。。。。。

小弟不才 最後都放棄 round robin(又不是全放棄) , 現在make左2個routing group. 第一個是default 行failover BB1/BB2, 第二個都是round robin ,只用做BT 和downloading.

頁: [1]

Powered by Discuz! Archiver 7.2  © 2001-2009 Comsenz Inc.