電訊茶室's Archiver

角色 發表於 2019-4-26 00:23

ESXi + MikroTik —— Routing and Switching

[i=s] 本帖最後由 角色 於 2019-4-28 20:19 編輯 [/i]

有了ESXi做platform,我们在这个platform之前可以建立很多VMs, 其中MikroTik routers,我们也可以configure MikroTik routers变成MikroTik switches,再加上vlan,有了这个平台,我们可以做很多很多的实验,而且这样的实验也能放在production用。

在使用ESXi,我们需要注意一些settings,不然在vlans,或者bridges都会出现问题。

如果你没有ESXi,你也可以考虑用VirtualBox,但是效能没有用ESXi强!在下面链接有不少的examples可以参考。
VirtualBox + MikroTik (RouterOS)[url=http://www.telecom-cafe.com/forum/viewthread.php?tid=7139&highlight=Virtualbox]Link[/url]

选什么Intel-based machine安装ESXi?可以参考 [url=http://www.telecom-cafe.com/forum/viewthread.php?tid=7388&extra=page%3D1]Link[/url]。

角色 發表於 2019-4-26 00:23

[i=s] 本帖最後由 角色 於 2019-4-28 18:53 編輯 [/i]

要注意的地方:

[list]
[*] How to configure virtual switches as virtual LAN cables? [url=http://www.telecom-cafe.com/forum/redirect.php?goto=findpost&ptid=7427&pid=46796]Link[/url]
[*] How to change the default identity of MikroTik routers? [url=http://www.telecom-cafe.com/forum/redirect.php?goto=findpost&ptid=7427&pid=46821]Link[/url]
[*] How to set up DHCP-client? [url=http://www.telecom-cafe.com/forum/redirect.php?goto=findpost&ptid=7427&pid=46822]Link[/url]
[/list]

角色 發表於 2019-4-26 00:23

备用帖子3

角色 發表於 2019-4-26 00:24

备用帖子4

角色 發表於 2019-4-26 00:24

备用帖子5

角色 發表於 2019-4-26 00:24

备用帖子6

角色 發表於 2019-4-26 00:24

备用帖子7

角色 發表於 2019-4-26 00:25

备用帖子8

角色 發表於 2019-4-26 00:25

备用帖子9

角色 發表於 2019-4-26 00:25

备用帖子10

角色 發表於 2019-4-26 00:26

备用帖子11

角色 發表於 2019-4-26 00:26

备用帖子12

角色 發表於 2019-4-26 00:26

备用帖子13

角色 發表於 2019-4-26 00:26

备用帖子14

角色 發表於 2019-4-26 00:27

备用帖子15

角色 發表於 2019-4-26 00:27

[i=s] 本帖最後由 角色 於 2019-4-26 08:50 編輯 [/i]

How to configure virtual switches as virtual LAN cables?

有的时候我们把VMs连起来是需要用到port group(就是把VM的LAN port grouped起来)而port group需要ESXi的virtual switch,如果你不更改预定的settings,经常会出现一些你不会遇见的问题。我们一般的想法就是把VMs用一个我们常用的LAN cables把VMs的ports连起来就那么简单。

下面描述怎样做的过程:

A: Create a virtual switch
1、进入ESXi console panel
2、点击[Networking] -> [Virtual switches] -> [Add standard virtual switch]
3、Vswitch Name = vsw-example (自己定)
     Uplink(untick,不选)
     Link discovery -> Mode = <none>
     Security, Promiscuous mode=Accept, MAC address changes=Accept, Forged transmits=Accept
4、Click [Add]

B: Create a port group
1、进入ESXi console panel
2、点击Networking -> Port groups -> Add port group
3、Name=Cable1 (自己定)
     VLAN ID=4095 (就是port group接受所有的VLAN ID data,如果不这样改,你想要的VLAN traffic都通过不了)
     Virtual switch=vsw-example(选之前create的virtual switch name)
     Security=(不用理会,会自动跟virtual switch vsw-example的settings)
4、click [Add] button

角色 發表於 2019-4-28 18:31

How to change the default identity of MikroTik routers?

You may use the following command:[code]
/system identity set name=<new identity name>
[/code]

角色 發表於 2019-4-28 18:52

How to set up DHCP-client?

Supposed we would like to set up DHCP client service at interface "ether1".[code]
/ip dhcp-client add interface=ether1 disabled=no
[/code]

頁: [1]

Powered by Discuz! Archiver 7.2  © 2001-2009 Comsenz Inc.